Service Outage | Single Sign-on

Resolved

IT teams have implemented a fix for some students experiencing issues with SSO. This is resolved.
Posted Aug 27, 2026 - 23:11 EDT

Investigating

IT teams are investigating reports that some students are unable to sign in to Single Sign-On (SSO) applications, including the Student Hub and Canvas. Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 27, 2026 - 22:28 EDT
This incident affected: Account Access and Security (Single Sign On (SSO)).